this post was submitted on 14 Aug 2025
322 points (96.3% liked)
Programmer Humor
26026 readers
1304 users here now
Welcome to Programmer Humor!
This is a place where you can post jokes, memes, humor, etc. related to programming!
For sharing awful code theres also Programming Horror.
Rules
- Keep content in english
- No advertisements
- Posts must be related to programming or programmer topics
founded 2 years ago
MODERATORS
you are viewing a single comment's thread
view the rest of the comments
view the rest of the comments
I mean aside of the variable name, this is not entirely unreasonable.
I would certainly rather see this than
{isAdmin: bool; isLoggedIn: bool}
. Withboolean | null
, at least illegal states are unrepresentable... even if the legal states are represented in an... interesting way.Admin false LoggedIn false doesn't feel illegal to me, more redundant if anything
I was thinking of the three legal states as:
null
or{isAdmin: false, isLoggedIn: false}
)false
or{isAdmin: false, isLoggedIn: true}
)true
or{isAdmin: true, isLoggedIn: true}
)which leaves
{isAdmin: true, isLoggedIn: false}
as an invalid, nonsensical state. (How would you know the user's an admin if they're not logged in?) Of course, in a different context, all four states could potentially be distinctly meaningful.ah you are right! i am so dumb.
Honestly logged in is state and shouldn't be on the user object.
The variable name is 90% why this is so unreasonable. Code is for humans to read, so names matter.
E: omg forget my whole comment. I agree with you that the name sucks.
I mostly don't like that
role
is typically an intuitive name, and now suddenly it means something I wouldn't expect. Why add confusion to your code? I don't always remember what I meant week to week, much less if someone else wrote it.If I had a nickel for every time that happened to me, I’d still be poor, but at least I’d have several nickels. 😁
Product manager: "I want a new role for users that can only do x,y,z"
Developer: "uh.. yeah. About that... Give me a few days."
Hmmm I need a datatype with three states... Should I use a named enum? No, no that's too obvious...
Yeah let’s use a union of a boolean and null to represent role, something that inherently represents more than two (…or three, I guess) different values, as opposed to something like an integer.
Even if the name is clearly misleading in this specific case, the entire choice of using a bool here is just bad because it’s almost guaranteed you’re going to expand on that in future and then you’ll just have to entirely rewrite the logic because it simply can’t accommodate more than two values (or three with the null union… 🙈), while it gives absolute zero benefits over using something more reasonable like an integer to represent the roles, or in this case, admin, not-admin and guest. Even if you’ll end up with just admin, non-admin and guest, the integer would still work great with no disadvantages in terms of amount of code or whatever. Just increased legibility and semantical accuracy.
Not to mention that there’s zero reason to combine the state of being logged in and the role in which you’re logged in in one variable… those are two different things. They will remain two different things in future too…
I mean they’re already chaining elseifs (basically matching/switching, while doing it in an inefficient way to boot 🥴) as though there were an n amount of possible states. Why not just make it make sense from the start instead of whatever the hell this is?
This is quite reasonable, aside from the variable name which should be
isAdmin
. A user either is an admin, or isn't. Unless we don't know, then it's null. You are correct this is bad if the point was to represent roles, but it's not supposed to.Admin is a role though, was my point. And besides, if you check for three different states, and you decide to go with a boolean to represent that, I really find it hard to believe anyone would think it reasonable. It’s valid and it’s practical, but can you really say it’s reasonable?
I don’t do typescript, but wouldn’t a union of a null and a bool be just more resource intensive than simply using an unsigned byte-sized integer? I struggle to find reasons to ever go for that over something more reasonable and appropriate for what it attempts to represent (3 distinct states as it stands, and likely in future more than just 3 when they have a need for more granularity, as you’d often do with anything you’d need an admin role distinction in the first place), but likely I’m just not familiar with ts conventions. Happy to hear the reasoning for this though.
My preferred way of modelling this would probably be something like
role: "admin" | "regular" | "logged-out"
or
type Role = "admin" | "regular";
role: Role | null
depending on whether being logged out is a state on the same level as being a logged-in (non-)admin. In a language like Rust,
enum Role {Admin, Regular}
instead of just using strings.
I wouldn't consider performance here unless it clearly mattered, certainly not enough to use
role: number
,which is just about the least type-safe solution possible. Perhaps
role: typeof ADMIN | typeof REGULAR | typeof LOGGED_OUT
with appropriately defined constants might be okay, though.
Disclaimer: neither a professional programmer nor someone who regularly writes TypeScript as of now.
Yeah obviously with constants for the set roles per value. Some languages call them enums, but the point is that what we pass and use is always still the smallest integer type possible. With the extra bonus that if the roles ever become composable, the same value type would likely suffice for a bitflag and only thing needing refactoring would be bitshifting the constants.
But anyway, this turns out to be the weirdest hill I find myself willing to die on.
So in a language with nullable types, are you against a boolean ever being nullable? Null means "empty, missing info". Let's say we have
role
variable with a enum type of possible roles. It could still reasonably be nullable, because in some scenarios you don't know the role yet, like before log in.In any use case where we need to store some boolean, it's a common occurrence that we don't have the data and it's null. It would be overkill to use an enum with
True
,False
,NoData
for these cases, where there is already a language feature made just for that, nullable values.I've never used TypeScript, just writing from experience in other languages.
Yeah, but if it is about being an admin or not, hence the bool, it’d be idiomatic and reasonable to assume it to be false if we have no data. Unless we want to try and allow admin access based on no data. Having three states for a simple binary state is weird. And if it is not about just being an admin or not, the bool is inherently a too limited choice for representation.
Depends on your requirements.
If the admin status needs to be checked in a database, but most actions don't require authentication at all, it's pointless to waste resources checking and it would be left null until the first action that needs the information checks it and fills it in as true or false.
I don’t really follow you there, wouldn’t it be exactly the opposite and wouldn’t checking for nulls be, as a premise, more wasteful? But doesn’t really matter, time to digress. I’m conventionally educated as an engineer so what I know and find reasonable today might be outdated and too strict for most contemporary stuff.
Let's say you have a website receiving 1 million requests per day. 0.01% of those are admin requests that need to know if your are an admin to execute them. It would be wasteful to check with the database if you are an admin for every request, when only a tiny minority of then needs to know that. So for 999.900 of the requests
isAdmin
will benull
. We don't know if the user is an admin and we don't need to know.That all is besides the point. There’s no real advantage to use null instead of defaulting to false there… it’s semantically more accurate and also less wasteful in that other code does not have to worry about nulls which always leads to unnecessary overhead when false is already equivalent in your proposed example.
It is not more accurate nor less wasteful. If you default it to
false
and you have 100 admin requests in the session where that variable is stored, you would have to check with the database 100 times. Because you are conflatingfalse
to mean two things: "the user is not an admin" and "we don't know if the user is an admin". Where if you set it totrue
orfalse
the first time we need the information, then subsequent requests don't need to check anymore.I am used to null safe languages where there is no such thing as worrying about nulls, because not checking for null on a nullable type is a compile error, and so it's impossible to forget about the null case. Maybe it's why I don't see any issue with using them.
That is all just external implementation details. Not sure if it was you or someone else, but the main argument in defense of the OP as in it reasonable, was that the name is wrong. That it ought to be idAdmin. None of what you just described should have anything to do with user being or not being an admin. In place of checking “isAdmin” for null, the semantical and resourcewise equivalent would be a third variable for “admin rights having been validated” or whatever. Conflating it in this one variable while renaming it to isAdmin or similar, would be even less sensical.. what if somewhere else in the code you have to check whether the initial validations have been made (while the actual role or whether is admin or not is irrelevant), you’d have to check if isAdmin equals null, which in that context would be confusing, ambiguous (i.e someone reading that bit will not know this is what is being checked without additional documentation) and just a code smell in general. You do want to make the important things unambiguous and self-documenting. Even more so the bigger the codebase is and the more contributors there are across its lifetime and in parallel at any given time.
But if we go with the original meaning of roles overall, then the union type is just a code smell that warrants a proper role thing around it.
Then you'd need to do something else.
So you are advocating for:
Over:
To me,
Filters(isAdmin = true)
is a very easy to use API, whereFilters(isAdmin = true, filterByAdmin = true)
, with the additional variable to avoid nullable booleans, is more verbose, for not much benefit and brings ambiguity. What if someone writesFilters(isAdmin = true)
, but forgets they need to setfilterByAdmin = true
for it to actually work? Easy mistake to make. We can prevent these mistakes by removing default values so they have to be specified on the call site, but then you needFilters(isAdmin = true, filterByAdmin = true, isConfirmed = false, filterByConfirmed = false)
, which is very verbose. Having two variables also allows your systems to get into invalid states:isAdmin = true, adminRightsHaveBeenValidated = false
isAdmin = true, filterByAdmin = false
What do these mean? It's better for invalid states to be unrepresentable. Since these states are mutually exclusive, we should have only 3 states, not 4 which you get with 2 booleans. Which you could achieve with an enum
True
,False
,None
, but then you are just reinventing the wheel of nulls. You also get the issue that now you have to remember to always update both variables together.It all comes back to your point:
You want to have ambiguous states, where a single value represents both "we have no data" and "we have the data, the answer is no".
Precisely my point.
And I’m not advocating for any of that. That’s just weird design, both of them, and as such a good example of something that warrants a bigger redesign in general.
Just advocating for clear, sensible, self-documenting and most importantly, expandable and maintainable code.
What’s idiomatic varies between languages and the conventions aren’t the same even then, when arguing across disciplines. This discussion seems to be more about different educations. I can get your point but from my personal experience in academia and working in the field it sounds undesired. But that’s just it. My, as in extremely limited, perspective. From your pov what you argue here is probably equally correct to what I think from mine is from my pov, it’s just a difference in the segment of the field we work in I suppose. Or plain old cultural differences.
Whichever it is, I bet we both can find better use for our time. I’m thankful for the time and effort though, even if I wasn’t persuaded. Sorry to have prolonged it so.